Adverti horiz upsell

"Rapid Rig: Modular" - Procedural Auto Rig 2.4.2 for Maya (maya script)

"Rapid Rig: Modular" frees you from the confines of bipedal autorigs! So get creative!

License
$99.00
(qty: 1)

  • Check 16 Future Updates Included
  • Check 16 Highend3d Quality Checked
  • Check 16 Purchase Guarantee
  • Check 16 Support Included

Compatibility

  • 2019, 2018, 2017, 2016, 2015, 2014

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:10/02/2013
Last Modified:05/02/2019
File Size: 321 KB

Q/A

is there a difference in private and comm vers ?

Date:07/22/2017
Submitted by: ziggie ziggie
Hi Dustin
 
man, this is one awesome rig system, thank you for creating it 
 
I purchased one version few days back for my personal use and script is working on my home computer without any issues.
 
 However, I also managed to convince peeps at work to purchase the same script for me, and when I installed it at work first thing I've noticed is script holds some additional options that I don't have in my private personal version, so I was wondering is this something you planned ( like, have you created one version for personal use and other for commercial ) or you didn't and this is some kind of a bug with my private version ?
 
I have attached jpeg for you too see what I mean my '' missing '' options.
Thank you for you help, keep up the awesome script updates
Peace !
 
 
 

Replies to this question:

  • Dustin Nelson

    Dustin Nelson said almost 2 years ago:

    I am not sure how they would be different. Unfortunately I cannot exand the image to see exactly what's going on. Any chance you can post larger ones? There isn't a different version for private or personal. They should appear and have the same functionality.
     
    -Dustin
  • ziggie

    ziggie said almost 2 years ago:

    Hi
    sure, no prob.
    I'll post you another '' higher '' res picture as soon as I'm home. ( at work currently ) 
    N.
  • ziggie

    ziggie said almost 2 years ago:

    Hi again Dustin,
    Ok, so I couldn't do anything with my home script yesterday due to this site, it was in '' maintainance '' for almost entire day but I'll def give it a try today. As for the script at work, its working correctly, but I'm not entirely sure if my rigs from old version ( .1.6 ) were are automatically updated to new version of the script. It says, to check the current version of the script I should select the Main controler, and when I do that and ask for the version evaluation it says the rig is still ( 1.6 ), even though I manually replaced all the files in the maya dir. ( where I alrdy had the previous files ) and then to make sure I'm running the correct version used the line od code to actually activate the 1.7 version.So, my question is, if I resave my scene with my new version od script, will it automatically '' upgrade '' all the rigs i've made prior to 1.7 to 1.7 or will it leave them in the 1.6 ( or this doesn't matter at all ? ) 
    I'm asking this because I already tried that and it's not really working, so, i could def use your help with this, sry to bother :(
    many thx
    N.
  • Replyindent
    ziggie

    ziggie said almost 2 years ago:

    message didn't went trough, can u repost your last reply ? 
    thx
  • Replyindent
    Dustin Nelson

    Dustin Nelson said almost 2 years ago:

     
  • ziggie

    ziggie said almost 2 years ago:

    Hi again Dustin,
     
    ok, I have some good news and some questions regarding the new version of the script.
    I've finally got the script to work for my home version and now I can see the menus and all the '' missing '' parts from within the selector that were absent before. However, I have some questions regarding the old and new version of the script regarding compatibility issues. For example, I have this bipedal character rigged and skinned in old scrpt version, but now when I try to select the '' skinning joints '' ( yes, it is a game character so single join hierarchy is used ) i get this error : 

    // Error: file: C:/Users/ZOLTAN/Documents/maya/2016/scripts/RapidRig_Modular_V2.mel line 23527: No joints have been created yet.

    and if I try to use selector while I do indeed have my built rig and everything, it says this : 

    // Warning: file: C:/Users/ZOLTAN/Documents/maya/2016/scripts/RapidRig_Modular_V2_Selector.mel line 3535: Your scene has no RRM Rigs in it

    my first thought was that this is somehow related to namespace ?

    so, yea, basically, this is the recap, script and selector are both working ( tested them out on a new clean preset rig i created only for that purpose ) 

    any thoughts on your side ?

    cheers again, much appreciated

    N.

  • Dustin Nelson

    Dustin Nelson said almost 2 years ago:

    That's annoying. This has happened before where posts do not post correctly.
     
    "Select Skinning Joints" isn't working likely because you don't have the rig loaded into the text field in Step 3.2. When you first generate the rig, the rig's name is auto-loaded into this field, however if you reload the UI, you have to load the rig in. This is because you may have multiple rigs that you may want to select the joints from, so this allows you to choose which one you want.
     
    In regards to upgrading the rig, simply loading the UI does just that. It makes no changes to anything in your scene. To upgrade your rig, you need to rebuild the rig with the version of the tool you are using.
     
    The Selector script currently will work with one namespace. Does your rig have more than one namespace (more than one ':' in the names of the nodes)?
     
    -Dustin
     
     
  • Replyindent
    ziggie

    ziggie said almost 2 years ago:

    Hi Dustin and thx for your reply
     
    ok, so I can tell you for sure that the first solution is not working since I already did that prior to posting my last message, so lets say it's not '' that ''. but, what you mentioned about the namespaces could be a good lead i'll go in that direction further on. Prob with Maya is that program totally messes up namespace conventions if you reference a geometry in your scene upon which you'll be building your rig, and if for some reason Maya decides to crash it will '' add '' new name to already existing namespace which then renders everything in your scene completely useless. So, i'll see if I can somehow '' clean '' the scene from any incorrect names, we'll see if it works. Yesterday i tried to rebuild my rig using the same method you described here but, didn't end well :( Once I have more info on this I'll get back to you, many thx for your help 
    N.
  • ziggie

    ziggie said almost 2 years ago:

    Hi Dustin
     
    Ok, I've tried couple of things so far, noone of them did the trick :( Anyhow, I'll try to explain what exactly happened ) or IS happening ) so that you don't get confused, I know I am.
    Basically, when I bought the script vers. then was 2.1.6 and it looked entirely different then the script 2.1.7 now, like I mentioned before, it was missing a lot of tabs and options, and selector was as you already know totally different.
    So, I've created my first rig with that script, a bipedal character for my personal animation i'm trying to do, fairly simple rig with nothing extra in it. Few days back you updated the version to 2.1.7 and I've seen great results in the '' main '' script window, tabs appeared and everything is working fine basically. But, what I cannot get to work at all is '' upda ting '' my rig to current script's version, or to be more exact If I try to use selector it fails to load up the screen since it's not '' reading '' existing rig in the scene. You mentioned namespace problems and I think this problem is direct result of that and here's why. In previous version if you were satisfied with your proxy rig and you were rdy to generate the control rig you HAD to name it otherwise generating process wasn't gonna go through with rig creation. So, I've named my rig and it added '' prefix '' to the new control rig and all its elements.Now, first thing I noticed in the new version is that you allowed the script to be generated without custom prefix name for the control rig like before, and now, since this is the '' new '' version to which I updated just few days back it seems to me that selector is '' looking '' for default name of the control rig in the scene which is '' control rig '' and not '' sdfjshfdjsf_control_rig '', or this is completely wrong assumption on my part ? I've tried to '' rename '' and to '' remove '' the prefix from the control rig in order to '' test-out '' this theory i have but as you know, nodes and everything regarding the control rig is completely '' locked down. That's one part of the problem, and now I'll try to explain the second part. OK, so, I'm stil in the scene with the same character, and If I select my Main_Ctrl to check the RRM ver number it says : The rig '' this-and-that '' is version 1.8.3 ?!? now, isn't this weird ? how in the..( was what I thought to myself :) ) of course, first thing you notice is, this rig is called '' this-and-that '' due to the fact that I had to give it a name in previous version, so therefore it's showing me the name in this version, even though in new ver. name is not relevant, or necessary like before ( Ive attached jpeg that shows this )
    Any thoughts on you side, we kinda '' chewed '' through this already but I still don't get it :(
    Many thx man, all best
    N.
     
     
  • Replyindent
    Dustin Nelson

    Dustin Nelson said almost 2 years ago:

     
  • ziggie

    ziggie said almost 2 years ago:

    As prior reply, this to didn't quite get through, rlly annoying I agree :(

Post a reply: