Adverti horiz upsell

"Rapid Rig: Modular" - Procedural Auto Rig 2.4.2 for Maya (maya script)

"Rapid Rig: Modular" frees you from the confines of bipedal autorigs! So get creative!

License
$99.00
(qty: 1)

  • Check 16 Future Updates Included
  • Check 16 Highend3d Quality Checked
  • Check 16 Purchase Guarantee
  • Check 16 Support Included

Compatibility

  • 2019, 2018, 2017, 2016, 2015, 2014

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:10/02/2013
Last Modified:05/02/2019
File Size: 321 KB

Bugs

Joints misalign when loading saved shapes

Statusclosed
Priorityhigh
Date04/08/2014
Submitted bybrandelan brandelan
Heya, so here's the workflow.  I make my rig, futz with it, get my control shapes all set up, then noticed an issue, so I saved out my shapes and deleted the rig.

I then fixed the issue, and re-built the rig, and when I loaded the control shapes, the roll joints in the legs went screwy.





The roll joints in the leg bow inward.

Having to re-shape my controls after every re-rig would be really annoying. 

Comments on this bug:

  • brandelan

    brandelan said about 5 years ago:

    Alright, to fix this, I went into the .ma of the control shapes that your tool saves. I removed any chunks of code that began with: if (`objExists boyRevised_r_Leg_Lower_Curve.... if (`objExists boyRevised_l_Leg_Lower_Curve... if (`objExists boyRevised_l_Arm_Lower_Curve... if (`objExists boyRevised_l_Arm_Upper_Curve... I assume that your save shapes tool accidentally saves the roll joint curve info and does something hinky when it saves them?
  • Dustin Nelson

    Dustin Nelson said about 5 years ago:

    Yeah the curves that the roll joints are attached to are likely added to the controls that are being saved. In the next update I will make sure they are excluded. Thanks for the detailed description, it makes my life a lot easier for me to determine what's wrong.
  • Dustin Nelson

    Dustin Nelson said about 5 years ago:

    I fixed this bug in version 1.2.2 so new rigs will no longer have this problem. Let me know if it works correctly now for you. Thanks! -Dustin

Post a comment: