Adverti horiz upsell

May9 Next, an alternative user experience 10.3.3 for Maya (maya plugin)

May9 Next, an Autodesk Maya workflow plug-in

License
Button download
5,455 Downloads

Compatibility

  • 2021, 2020, 2019, 2018, 2017

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:08/03/2016
Last Modified:04/05/2021
File Size: 1.15 MB

Bugs

May9_MMs.mel error if Arnold is not loaded

Statusclosed
Prioritymedium
Date04/08/2019
Submitted byDavide Alidosi Davide Alidosi

May9 Next, v10.1.0

 
Error in May9_MMs.mel
 
string $myArnoldVersion = substituteAllString(`pluginInfo -q -v mtoa`, ".", "");
int $myArnoldIntVersion = `substring $myArnoldVersion 1 3`;
 
// this errors out if mtoa.mll is not loaded
 
// I use this workaround, but it would be nice if this is accounted for
 
string $myArnoldVersion;
int $myArnoldIntVersion;

if(`pluginInfo -q -l mtoa`)
{
    $myArnoldVersion = substituteAllString(`pluginInfo -q -v mtoa`, ".", "");
    $myArnoldIntVersion = `substring $myArnoldVersion 1 3`;
}
 
 
Thanks. keep up the good work!

Comments on this bug:

  • cra Gato

    cra Gato said almost 3 years ago:

    You are welcome,
    Carlos Rico Adega (@CharlieWales)
  • Davide Alidosi

    Davide Alidosi said almost 3 years ago:

    Thanks man, I've apply your fix into release Next.1.1

Post a comment: